Ottawa Power Outage
Incident Report for Staging - Stax Bill
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 08:21 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 25, 2022 - 15:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 25, 2022 - 15:01 EDT
Update
We are continuing to investigate this issue.
Posted May 25, 2022 - 15:01 EDT
Investigating
The city of Ottawa where the Fusebill headquarters is located experienced a storm on Saturday, May 21st, 2022. As a result, the Fusebill staging environment, and phone system is currently down.

The City has been working to restore power. Ottawa Hydro is building bypasses to circumvent the massive amount of downed power lines, which may speed things up.

Our production environment and support email are still online.

The best way to reach support is support@fusebill.com

We appreciate your patience, understanding, and cooperation
Posted May 21, 2022 - 15:01 EDT